Problem with disabled WiFi and Unknown USB Device (Device Descriptor Request Failed)

TLDR:
disable unknown USB device -> disable wifi -> hibernate -> plug off power cable -> turn on laptop –> enable wifi

WiFi card: Intel(R) Wireless-AC 9560 160MHz

Errors:
Error (status): This device cannot start. (Code 10)
Error (status): Windows has stopped this device because it has reported problems.
(Code 43)

When fail all methods that you try from internet to turn on Wi-Fi try this (for me works on ASUS ZenBook):
Go to Device Manager -> Universal Serial Bus controllers -> right click on Unknown USB Device (Device Descriptor Request Failed) -> Disable device

Error: Windows has stopped this device because it has reported problems. (Code 43)

Unknown USB Device (Device Descriptor Request Failed)
Code 43

Go to Device Manager -> Network Adapters -> right click on your wifi device (Intel(R) Wireless-AC 9560 160MHz in my case) -> Disable device

Error (status): This device cannot start. (Code 10)

Intel(R) Wireless-AC 9560 160MHz – Intel(R) Wireless-AC 9560 160MHz
Error (status): This device cannot start. (Code 10)
Disable devices

Next Hibernate system.

Then unplug the power cord, if connected.

And next turn on system and once again go to device manager. Then just turn on the network device and finally the Wi-Fi should work:

Intel(R) Wireless-AC 9560 160MH works

I bet that’s some kind of power management problem.

And in my case problem is on Windows 10, maybe update to win 11 will solve it.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

%d bloggers like this: